View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: so how do you get that rotor moving on my models
PostPosted 15.05.2012, 02:24 
just wondering how without using script my imported 3Dsmax heli 's i made need to be set up
is there a way in the editor to add rotor or wheels to a model.
and if not what is the right working way to set up my rotor names in 3d max
im a compleat noob but have a nice set up of helis that i cant get rotor running and
the seat, booster placement is off.
:whistle:

User avatar   Uber Modder Uber ModderMember since: 21.10.2011, 23:50Posts: 1731 Likes: 8
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 15.05.2012, 14:18 
Mayber per Vehicle Editor...
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 15.05.2012, 19:49 
ya can someone tell me where in editor tree the setting for the rotor animation is.
and what do i do to get them to work on the models. even there demo basic model dont seem to alow anamations.
anyone have any helpful direction with the veh editor. there is no u tube action on this issue??
User avatar   Trained Modder Trained ModderMember since: 27.06.2010, 17:54Posts: 382Location: Canada Likes: 25
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 15.05.2012, 21:45 
for a rotor animation you actually have to export the animation from max
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 15.05.2012, 22:42 
so in max make 3 rotors
named
rotor
rotor_proxy
rotor_blur
and export as a cga and use the animation from the black hawk is a dead issue
anyone know how to set up this in max. i have some models just waiting for rotar action.
and im not shure the right words used with vehical editing to get the models anamated
thanks for the help and guideance cryfriends, where not alone
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 17.05.2012, 20:12 
seems there is little support and info on the vehical editor, i wish i had some nice key diagrams for how to rig a heli, and tank animation. so i can make some movies lookin real
User avatar   Trained Modder Trained ModderMember since: 27.06.2010, 17:54Posts: 382Location: Canada Likes: 25
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 17.05.2012, 21:46 
I really dont know how to explain this. I learned through trial and error but you have to export the animation as a separate file in the same folder as the cga. More info on exporting the animations here: http://freesdk.crydev.net/display/SDKDO ... Animations
Then you have to make a XML. file for the actual vehicle to make it drivable look at the other files from the default vehicles. Good luck!
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 18.05.2012, 20:38 
is there some science to this
i have the heli up and running using the xml from the H60 then armed it with a connon and fixed the seating
but the anamation file that is in the folder with the cga and xml does nothing
is there somthing im missing or could it be the naming .
i think i screwed up with the naming in the original cga
there is no doc on the right way to do this . im so close and have the anamation set to loop. if that was a issues. so where in vehical editor, is the link or comandes for rotors, could some one give me some editor direction please. or just post the xml il change my model to see the names
i have a rotor, rotor_proxy, and rotor_blur
or is it the white , red , im lost on this one
User avatar   Trained Modder Trained ModderMember since: 27.06.2010, 17:54Posts: 382Location: Canada Likes: 25
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 18.05.2012, 21:40 
yeah somewhere in the xml you have to specify which animation file to use
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 18.05.2012, 23:41 
so who knows what line in the xml needs changing
my model is called helitest, so somehwre in the xml there is a place to change from H60 to test heli.
anyone have a min to exsplain where in the the xml it is and il buy you a cup cake.
8o :evil:
  Trainee TraineeMember since: 24.04.2012, 21:21Posts: 121Status: Online Likes: 0
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 21.05.2012, 13:57 
there is no docs onj how to change this seems simple if someone would help
User avatar   Uber Modder Uber ModderMember since: 04.04.2010, 18:17Posts: 1389Location: Canada Eh ! Likes: 20
 

 Post Topic: Re: so how do you get that rotor moving on my models
PostPosted 29.05.2012, 22:59 
Here is vid tut on importing helis into cry engine. It was made for crywars, but same procedure still works fine for CE3.

wiki/index.php/Exporting_a_vehicle_from_3DMax_to_Crysis_(Video_Tutorial)

:D


Image