Tools Feedback & Support

View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Beginner BeginnerMember since: 23.05.2012, 18:29Posts: 2 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 23.05.2012, 20:13 
Thank you so much i couldnt even run the game until i had done this or even edit it. Thanks ALOT!!!

  Beginner BeginnerMember since: 23.05.2012, 21:33Posts: 3Location: Virginia Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 24.05.2012, 17:27 
Greetigns, This post was started back in April. Any updates with this issue?

I will apply the fix to my machine.


Sean R.
Maya 2012
Cry3 SDK (Free)
User avatar   Crytek Staff Member Crytek Staff MemberMember since: 09.01.2008, 01:11Posts: 10156Location: Crytek HQ Likes: 498
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 26.05.2012, 00:44 
Quote by Cry-Adam:
Just an update on this, we're still investigating this issue but it appears as though Geometry Instancing + Tessellated objects isn't currently supported which is why disabling GeomInstancing fixes the issue. The reason AMD drivers are crashing and NVIDIA cards aren't is simply one driver falls on the issue and one doesn't. Will keep you posted on advancements but the official fix is as per the OP, to disable r_GeomInstancing. Thanks!



Image
Image
No dev/modding PM's please, use the forums! :)
User avatar   24/7 Modder 24/7 ModderMember since: 12.04.2007, 16:51Posts: 3271 Likes: 2
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 26.05.2012, 03:18 
Ill try it.. just cuz i want to play the demo.. Im almost done porting the assets to C2..
Guess this is working from other posts.. so thanks
  Beginner BeginnerMember since: 26.03.2011, 23:25Posts: 92Location: Berlin Likes: 2
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 10.06.2012, 21:44 
Fixed it for me.

AMD has to get their **** together soon man, have CryTek already contacted them about this?
  Beginner BeginnerMember since: 30.08.2011, 22:28Posts: 2 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 10.06.2012, 21:51 
Can't get it to work for me. I've tried every way I can think of and nothing works.
User avatar   Trained Modder Trained ModderMember since: 19.08.2011, 23:34Posts: 273 Likes: 18
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 14.06.2012, 03:25 
seems to work so far with that small temporary fix on both machines. i7 AMD Graphics and the other with all AMD hardware.


Don't PM for help, post so that everyone can respond.
  Beginner BeginnerMember since: 30.06.2012, 00:34Posts: 1 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 30.06.2012, 03:21 
I got the same problem. Im using an HD4850. I tried both the commands but still facing the issue :(
  Beginner BeginnerMember since: 29.10.2011, 09:38Posts: 8 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 04.07.2012, 11:46 
Quote by Cry-Ruan:
Hi guys,

Figured we're getting enough separate threads on this; we're currently aware of the issue whereby geometry instancing crashes the SDK using the D3D11 renderer on AMD cards. Original thread is here.

Workaround
Enter r_GeomInstancing = 0 into your system.cfg to prevent these crashes, or r_Driver = DX9 to revert to the D3D9 renderer.

Your system.cfg is found in the root folder of the SDK. At present we're working on the issue. If you have any useful information to add, please do so here :)

Cheers,
Ruan
How do you get to the root folder of the SDK from the Start Menu?
User avatar   News Posters News PostersMember since: 04.12.2007, 03:23Posts: 10442Location: Hamar, NorwayStatus: Online Likes: 517
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 04.07.2012, 11:50 
My Computer? Or Start -> Run -> HDD:\Foldername


 
 
 

< Vascotia Studios >

Image   Image   Image   Image   Image

NO support via PM!
  Beginner BeginnerMember since: 29.10.2011, 09:38Posts: 8 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 04.07.2012, 12:09 
Quote by Lavizh:
My Computer? Or Start -> Run -> HDD:\Foldername

Problem is, when I installed the SDK, there is no application to open it other than the DirectX Control Panel. Do you happen to know the exact name of the folder?
  Beginner BeginnerMember since: 13.07.2012, 07:31Posts: 1 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 13.07.2012, 07:52 
Good morning guys. I am new to the world of crydev. I am trying to install the sdk under win 7 64 bit (with ATI 6770M) and I get error 183. I have implemented the corrections mentioned but the editor still crushes. Any ideas, thanks in advance!
  Beginner BeginnerMember since: 19.07.2012, 18:29Posts: 1 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 19.07.2012, 21:02 
Quote by XzQshnR:
I got the same problem. Im using an HD4850. I tried both the commands but still facing the issue :(

I also use an HD 4850 (yeah I know time to upgrade.) and the workaround doesn't work for me.

EDIT: apparently I had two problems, the editor stopped crashing but I only see a black screen. I can load the included forest map, even enter game mode, move and fire but I can't see anything.
Attachments:

Game.log
[33.86 KiB]
Downloaded 32 times
error.log
[2.46 KiB]
Downloaded 31 times
Editor.log
[29.44 KiB]
Downloaded 26 times

  Beginner BeginnerMember since: 17.08.2012, 17:02Posts: 1 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 18.08.2012, 23:59 
I Have the same problem ,attached my dxdiag ?(

Any solution ?(, i try with r_GeomInstancing = 0 and not working
Attachments:

DxDiag.txt
[36.18 KiB]
Downloaded 37 times
  Beginner BeginnerMember since: 21.08.2012, 20:35Posts: 6 Likes: 0
 

 Post Topic: Re: Got an AMD card? Read this first!
PostPosted 22.08.2012, 12:03 
Quote by killereddy:
Quote by XzQshnR:
I got the same problem. Im using an HD4850. I tried both the commands but still facing the issue :(

I also use an HD 4850 (yeah I know time to upgrade.) and the workaround doesn't work for me.

EDIT: apparently I had two problems, the editor stopped crashing but I only see a black screen. I can load the included forest map, even enter game mode, move and fire but I can't see anything.


are in the same situation but I have a hd 5600 and uttilizzo win XP SP3 and DirectX 9c