Tools Feedback & Support

View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Beginner BeginnerMember since: 07.08.2012, 19:09Posts: 4Location: Texas Likes: 0
 

 Post Topic: Same problem for days... Colors won't render..
PostPosted 10.08.2012, 04:34 
I got CRYENGINE 3 a couple of days ago, and I am very new to designing with such an intricate editor. I used to map for Insurgency and CS:S but I would still say that I am a "newbie" when it comes to level design. To the point. I started watching an editor tutorial on Youtube, by moocowisback (http://www.youtube.com/watch?v=a42Obs62ses), and I have so far generated terrain, increased the water level to 80 and decreased the maximum height to 500.

Then I got to the texturing, and maybe it is just because I am brand new to this kind of editor or something, but I noticed that I can apply material to the terrain with no problem, but that is all I can do. It won't render the color that supposedly specific to each type of material. I also noticed that when I am in the texture manager and browsing the materials, there is a little lock button next to each drop-down box and material. Also, the white squares and black lines are still showing on the terrain.

Any help would be much appreciated. My Print-Screen key is not working, otherwise I would put up pictures.

User avatar   News Posters News PostersMember since: 20.01.2009, 02:39Posts: 2975Location: Glorious Texas Likes: 254
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 10.08.2012, 04:57 
The lock indicates it cannot be saved with changes. You can, however, duplicate the material and give it a different name and change it all you want. The changes will be there next time you load.
As for the other things, I need to see screenshots.
Open the console in the Editor (Go to View---> Open View Pane---> Console) and type "r_screenshot=2" without quotes and attach the photos. They should save in "My Documents"


Image
No support via PM
  Beginner BeginnerMember since: 07.08.2012, 19:09Posts: 4Location: Texas Likes: 0
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 10.08.2012, 05:25 
Got the screen to stop going black and did the panoramic screenshot. By the way it is "e_screenshot=2". :D
User avatar   News Posters News PostersMember since: 20.01.2009, 02:39Posts: 2975Location: Glorious Texas Likes: 254
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 10.08.2012, 06:13 
Hm guess that changed in CryEngine 3.
  Beginner BeginnerMember since: 07.08.2012, 19:09Posts: 4Location: Texas Likes: 0
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 11.08.2012, 05:26 
It looks like the one on the left, and it will not look like the one on the right.
Attachments:

  Beginner BeginnerMember since: 07.08.2012, 19:09Posts: 4Location: Texas Likes: 0
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 12.08.2012, 18:24 
I got some pictures of the terrain. The only reason that I am able to paint is because I have to change the color under Layer with the Layer Painter.

Let me know what pictures you need. I got my Print-Screen button to work.
Attachments:

Texture Problem.JPG
  Uber Modder Uber ModderMember since: 22.08.2011, 09:34Posts: 1578Status: Online Likes: 160
 

 Post Topic: Re: Same problem for days... Colors won't render..
PostPosted 12.08.2012, 19:31 
Hi Synnux, all the terrain textures have a default colour white, you have to select the colour you wish to paint with.

If you look at the diffuse colour of a texture in the material editor you will see it is 255,255,255 which is white.

This should help http://freesdk.crydev.net/display/SDKDO ... ng+Terrain

Also it helps to go to the bottom of the layer painter and use the change button an click on the terrain to make the tiles a larger resolution. Remember to generate surface texture from the main menu.