View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Trained Modder Trained ModderMember since: 31.10.2007, 12:05Posts: 357Location: Budapest, HungaryStatus: Online Likes: 9
 

 Post Topic: Rush gamemode (flowgraph only)
PostPosted 29.08.2011, 17:23 
Hi
Iam makeing a rush mode for C2, similar to the Bad Company rush mode.



Image Image Image

features:
-fully working activating/deactivating system
-the computers can be destoryed with weapons too (but they got a lot of hp)
-red flashing light when activated (not really visible in this video but its working)
-damages player at explosion
-the computers can only be destroyed in the correct order
-each computer got its own spawnpoints for attackers and defenders too (makeing the game going forward)
-currently it works with 4 destroyable computers, but the number can be relatively easily modified
-after destroying the last computer or after a pre set time the game ends with a message "xyz team win" and switches map with "g_nextlevel" command //this one is not tested yet

problems:
-display messages not working ingame (and its full of them in this version. other message nodes dont have enough settings)
-when i tried to export the flowgraph, then my friend imported it, it gave him errors, and things were missing from the flowgraph
-soundeventspots are absolutely not working for me (and for my friend, when he imported it). only if i press the activate in the rollup bar. so no explosion sound, and no "beep-beep-beep" when the bomb is activated
-currently both team can activate and deactivate the bomb


Last edited by KillingSpree on 30.08.2011, 19:18, edited 3 times in total.

User avatar   Skilled Modder Skilled ModderMember since: 01.12.2009, 22:36Posts: 736Location: Egypt Likes: 1
 

 Post Topic: Re: Rush gamemode (flowgraph only)
PostPosted 29.08.2011, 17:54 
- Display Messages aren't supposed to be viewed ingame by anyway. Use "Hud:ShowButtonHint" instead, not so bad :unsure:

- Flowgraph problem needs to be more explained and a huger screenshot to check it, anyway I can't guarantee you that I could help because I'm not good with pro Flowgraphs :p

- "Sound:PlaySoundEvent" through FG doesn't work? Give it a try :whistle:

Tell results and Good luck ;)


Image
  Trained Modder Trained ModderMember since: 31.10.2007, 12:05Posts: 357Location: Budapest, HungaryStatus: Online Likes: 9
 

 Post Topic: Re: Rush gamemode (flowgraph only)
PostPosted 30.08.2011, 19:17 
Quote:
- Display Messages aren't supposed to be viewed ingame by anyway. Use "Hud:ShowButtonHint" instead, not so bad :unsure:

Yeah..i know this now, but its a lot of unnecessary work to make it work nice with "showbuttonhint" (it dont have "position" setting, so i only can use 1 of it at once) and "showsuitmessage" (it dont "position" setting and "hide" option)...i started it.
Quote:
- Flowgraph problem needs to be more explained and a huger screenshot to check it, anyway I can't guarantee you that I could help because I'm not good with pro Flowgraphs :p

The problem is simply i cant export it without losses. May be with the map itself, but i will play with it later again. Hope that was a one time problem. :baby:
Quote:
- "Sound:PlaySoundEvent" through FG doesn't work? Give it a try :whistle:

Its done with FG, and not working for me. dont do anything, only if i press the activate in the rollup bar X(
User avatar   Skilled Modder Skilled ModderMember since: 01.12.2009, 22:36Posts: 736Location: Egypt Likes: 1
 

 Post Topic: Re: Rush gamemode (flowgraph only)
PostPosted 02.09.2011, 02:34 
You should assign an entity to the "Sound:PlaySoundEvent" which will the sound comes from it. Have you done that?


Image