View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Beginner BeginnerMember since: 16.01.2012, 01:00Posts: 9 Likes: 0
 

 Post Topic: SOLVED - Map not loading in MAP
PostPosted 16.01.2012, 02:16 
I made a multiplayer map with 4 Spawnpoints, a spectator point and the minimap thing. I'm pretty much done with it and would like to try it in game. However I can not access this map, not via console nor the "Create Game" Explorer.

At first I was able to see it's name in the explorer under Instant Action, now even that is gone.

I made another map real quick, using the same steps I've used on my first map and it works. So obviously I must at least know what I'm supposed to do.

At this point I'm really lost and don't know what else to try or do, as I have tried just about anything I could think of.

Could someone please download the map and give it a try ? I've attached the level folder. Get it to work in Multiplayer. Then either tell me what I did wrong or send me back the working files.

Please I need help with this, I'm tired of searching and reading new topics, spent just about the last 3 days doing that. X(


Last edited by Deadman-Inc on 17.01.2012, 19:25, edited 1 time in total.

User avatar   Beginner BeginnerMember since: 15.01.2012, 21:51Posts: 2Location: Turkey Likes: 0
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 16.01.2012, 13:18 
yourmapname.xml file

PowerStruggle

<MetaData>
<Gamerules MP1="PowerStruggle"/>
<MiniMap Filename="xxx.dds" startX="922.069946" startY="1038.659424" endX="3122.069824" endY="3238.659424"/>
<LoadingScreens screen1="xxxx.jpg"/>
<HeaderText text="xxxx"/>
<DescriptionText text="Your Massage"/>
<Display Name="xxxx"/>
</MetaData>

InstantAction
<MetaData>
<MiniMap Filename="xxxx.dds" startX="698.318481" startY="554.986023" endX="1522.318481" endY="1378.986084" mapRadius="50"/>
<Gamerules MP1="InstantAction" MP2="TeamAction"/>
<LoadingScreens screen1="xxxx.jpg"/>
<HeaderText text="xxxx"/>
<DescriptionText text="your massage"/>
<Display Name="xxxx"/>
</MetaData>


LioN Crysis Best Clan

Her Zaman Liderdik Şimdide Öyleyiz...
  Beginner BeginnerMember since: 16.01.2012, 01:00Posts: 9 Likes: 0
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 16.01.2012, 21:23 
Nah didn't help, as I said, I got other custom maps to work so its probably not my MetaData. Can someone please download the map and take a look ?

Thanks
User avatar   24/7 Modder 24/7 ModderMember since: 12.04.2007, 16:51Posts: 3272 Likes: 2
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 16.01.2012, 23:52 
from my past levels MP.. you might have an unauthorized entity in the level..
youve made other maps so maybe you forgot?
User avatar   Has no life Has no lifeMember since: 11.07.2008, 20:25Posts: 11738Location: Nottingham, UK Likes: 86
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 17.01.2012, 00:01 
I'm on the world's worst internet connection right now so I can't download it, but judging by the filename you've got a space in your level name. This isn't recommended.


Out now! CryENGINE Game Programming with C++, C#, and Lua
Ex-Crytek, now with Deep Silver Dambuster Studios
  Beginner BeginnerMember since: 16.01.2012, 01:00Posts: 9 Likes: 0
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 17.01.2012, 10:46 
I was thinking of spaces in the file name too. Therefore I changed it. The level folder still has two names "Banana Field" I renamed the level itself to Banana.cry
Not sure if that is correct.

It is possible that I have unauthorized items in the level. Is there a list or something so I can make sure ?
I know AI isn't allowed in Multiplayer, which I'm not using. It might be the weapons. I don't know if they are multiplayer specific or if they even respawn. How am I supposed to drop them into the level ? I think I just went through Entity - Weapons or something, perhaps not the correct way.

The rest is just standard things, building, vegetation, furniture.

Anyway, still hoping someone more knowledgeable than me could take a look.

Oh by the way, is there a game log or something like this, where I could possibly look for answers ?
User avatar   Uber Modder Uber ModderMember since: 19.09.2009, 09:30Posts: 2633Location: FinlandStatus: Online Likes: 177
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 17.01.2012, 18:25 
The folder name can't have spaces it in. The game loads the level.pak file, not the .cry file (Unlike the editor).
  Beginner BeginnerMember since: 16.01.2012, 01:00Posts: 9 Likes: 0
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 17.01.2012, 18:29 
I fixed that too by now. I am now able to load the map through the console as a singleplayer map. The weird thing is it just doesn't even show up in the Create Game explorer. It used to. :unsure:

Right now I'm replacing all the weapons, I drag and drop them straight from the Database view while having Respawn checked. Maybe that's why ?

Other than that I can't think of much. I do have a few exploding items and destructible buildings in the map, is that an issue with Multiplayer ?

Thanks for your input!
  Beginner BeginnerMember since: 16.01.2012, 01:00Posts: 9 Likes: 0
 

 Post Topic: Re: Map not loading in MP, can someone try?
PostPosted 17.01.2012, 19:24 
WOW! Ok now I'm at a loss. Its actually working fine now!
I got frustrated and just did the Metadata again and changed all the guns to respawn and made them unique. Now its working.
Either some small mistake in the Metadata I overlooked or god knows what.

Anyway, thank you guys so much for your help! Its awesome to see there's still people out there keeping Sandbox 2 alive!
See you on the servers!