View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: help, beginner here.
PostPosted 05.03.2012, 17:54 
hello,
I've barely downloaded the cryengine 4 hours ago. I've been trying to get a house imported from 3ds max and I've finally succeeded but now I have some weird looking shapes on the walls. can anyone help pls?
sry if I posted in the wrong section :xmas: Image

  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 06.03.2012, 20:22 
come on nobody??? :-<
User avatar   Experienced Modder Experienced ModderMember since: 30.06.2011, 13:37Posts: 457Location: Ottawa, Ontario - Canada Likes: 0
 

 Post Topic: Re: help, beginner here.
PostPosted 06.03.2012, 21:43 
there could be a number of numerous issues. lets start with the basics, the mesh check for Double geometry, then check UV's are not overlapping or out of the 0-1 space, make sure your normal's are smooth and hard where they need to be. Do not Use Base Lambert shader networks when Exporting mesh CryEngine prefers Phongs. Hope this helps :)


Image
  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 03:12 
ok, so the thing is I have a whole house (single mesh) that has a single material with 6 submaterials (the white walls, bricks, the hardfloor, etc). There are 2 submaterials that have a plain colour .tif as a diffuse map (the walls have a simple white .tif) and only on these 2 submaterials the visual error occurs. on the other 4 submaterials that have bricks or other texture .tif's as diffuse maps there are no visual errors.
I mapped it in 3ds max WITHOUT unwrapping it and for materials I used standard with crytek shaders.
It makes no sense that it's ONLY on these 2 submaterials that have visual errors.
I also checked it for double geometry. could it overlap with the collision boxes? but they are set as "no draw" from material in max so they shouldn't show at all right?
thanks for replying.
User avatar   Experienced Modder Experienced ModderMember since: 30.06.2011, 13:37Posts: 457Location: Ottawa, Ontario - Canada Likes: 0
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 07:10 
your collisions are not the issue my next suggestion is to fully unwrap it all this is what is most likely the issue. Projecting textures onto a mesh is not the best workflow for any game engine cause the engines use UV's it is pretty important if you want a another suggestion just separate the pieces and export them it may help.

again this will not replace proper workflow.
again again :) this may not be your issue i am just starting with the basics


Image
  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 12:18 
:D ty very much dude. I'm gonna start unwrapping right away and I'll let you know when I'm done if this solved it. Thanks.
  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 14:54 
ok so unwrapping didn't work. I also tried replacing the materials.
this is the original with simple colours as .tif on the walls and balcony
Image

in this one I replaced the wall diffuse map and added a specular and bumpmap too, although the diffuse map already had relieved me of the visual bug. the balcony still is with simple colour as .tif diffuse map.
Image

and in this one I applied a diffuse, spec and bump on both of the submaterials and as you can see it looks ok.
Image

so it's because of the materials. is there any way to disable the diffuse map and use just a simple colour from the mat editor in crysis? because if I just delete the path of the diffuse it just says replace me on a red background :p
User avatar   Uber Modder Uber ModderMember since: 15.01.2011, 23:00Posts: 1227 Likes: 28
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 14:57 
Quote by TonyBS:
ok so unwrapping didn't work. I also tried replacing the materials.
this is the original with simple colours as .tif on the walls and balcony
Image

in this one I replaced the wall diffuse map and added a specular and bumpmap too, although the diffuse map already had relieved me of the visual bug. the balcony still is with simple colour as .tif diffuse map.
Image

and in this one I applied a diffuse, spec and bump on both of the submaterials and as you can see it looks ok.
Image

so it's because of the materials. is there any way to disable the diffuse map and use just a simple colour from the mat editor in crysis? because if I just delete the path of the diffuse it just says replace me on a red background :p

So I always take a blank white texture and then change the color and bumpmap...did much of very nice looking textures with this...but I don't really get why your's shouldn't work...can you show me a screenshot of you material-editor settings?
  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 15:02 
Image
here you go.
you should note that I didn't change anything, it's the way it came when I've imported it from max.
thanks.
User avatar   Uber Modder Uber ModderMember since: 15.01.2011, 23:00Posts: 1227 Likes: 28
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 15:17 
Hmm...yeah looks okay, I don't know why this should happen. But I've actually never imported any model from 3ds to CE3 so maybe that's a problem with the exporter. Sorry, can't help you further then :unsure:
User avatar   Superstar Dolphin Superstar DolphinMember since: 16.08.2004, 10:46Posts: 9823Location: Finland Likes: 160
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 15:21 
The texture map doesn't fix the issue, it just hides it. You can see strange black shading at the top parts of the walls even with the brick texture applied. I'm betting that it's a smoothing error, if you disable the normal map you'll probably see similar strange shading artifacts on top of the diffuse map. :)

Make sure you have applied smoothing groups to the models in Max - even if a box-shaped object looks ok in the 3ds Max viewport it may look strange in Sandbox! By default Max assumes separate smoothing groups for faces that don't have smoothing groups applied, while Cryengine assumes a single smoothing group.
  Trainee TraineeMember since: 23.12.2011, 00:28Posts: 168 Likes: 1
 

 Post Topic: Re: help, beginner here.
PostPosted 07.03.2012, 17:43 
holy Sh*t, I played with those settings a bit, because I thought of the same thing at some point but I just cleared all smoothing groups and exported. Now I tried using auto smooth, it assigned some groups and it works :X
THANKS ALL :X