View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

User avatar   Beginner BeginnerMember since: 18.03.2012, 04:11Posts: 16 Likes: 0
 

 Post Topic: Proxy Issue
PostPosted 22.04.2012, 07:22 
I have created a bridge for this map I am working on, but I can't seem to get the proxy right. At first I forgot to create it and I fell through soon as I went to walk across it. So I went back into 3ds max and created my proxy. The problem I am facing now is I cant walk on the bridge at all.

When I made the proxy I went into vertex and lined it flush with the road, I also made the rest of the proxy's flush with the railings and so on. But when press ctrl g to test it I get stopped about a foot away from the bridge by the proxy.

Would someone be kind enough to post a more in depth tut on proxy for me. The tuts I have found don't really go into any details.

  Trainee TraineeMember since: 13.07.2011, 16:18Posts: 114 Likes: 1
 

 Post Topic: Re: Proxy Issue
PostPosted 22.04.2012, 10:19 
it may be that the proxy isn't lined up properly - have you reset x-form on both the proxy and the mesh?

Try putting p_draw_helpers 1 into the console - this will allow you to see your collision mesh in the engine and you should be able to troubleshoot the problem from there
User avatar   Beginner BeginnerMember since: 18.03.2012, 04:11Posts: 16 Likes: 0
 

 Post Topic: Re: Proxy Issue
PostPosted 22.04.2012, 21:05 
Quote by bazmod:
it may be that the proxy isn't lined up properly - have you reset x-form on both the proxy and the mesh?

Try putting p_draw_helpers 1 into the console - this will allow you to see your collision mesh in the engine and you should be able to troubleshoot the problem from there


Thanks for the reply. It seems as if none of my adjustments to the proxy have transferred over to the engine. On cryengine the proxy's are just large boxes. Also I did not reset the x-forms, The tuts I was following didn't say anything about that.

I'll give it a shot and see what happens.

Edit: Thank you, I managed to fix my bridge.