Tools Feedback & Support

View unanswered posts | View active topics


Post a new topicPost a reply
Previous topic | Next topic 

User avatar   Beginner BeginnerMember since: 30.08.2011, 07:23Posts: 1 Likes: 0
 

 Post Topic: Trouble with Sound Spots, Particle Sounds, and Roll offs
PostPosted 14.05.2012, 10:19 
First off, we're having problems getting two basic sound functions to work at all:

Normal Sound Spots do not work and attaching sounds to particle effects does not seem work at all. I've tried attaching sounds to both a parent and a child effect and neither seems to produce any sound. I was curious if anyone else have been experiencing these issues?


I'm also having a roll off issue with CryEngine 3. We're having to use a lot of Ambient Volumes due to the above happening and the roll off on certain sounds is extremely bad. It doesn't seem to matter how much I adjust the roll off or volume decrease in FMOD or in the editor. The sound itself always drops off dramatically once i hit a certain roll off range. Also I can have the main character be running away, the volume will decrease appropriately, then i stop and start moving again, the sound source will jump back up in volume and then drop out again. It is extremely noticeable if I'm moving the main character/camera directionally as well instead of just going front to back towards and away from the sound source. I've tried a ridiculous amount of different settings trying to figure out my problems and have done everything the SDK documentation suggests. (Unless I missed something)

For example if I run away from the sound source, stop, turn and look towards it (for some reason the volume actually decreases), turn back around and run away (the volume increases as i run the opposite direction and then immediately comes out as if it was at the end of its radius/roll off setting.

I just really for the life of me can't understand why I'm having this problem. I've never really had this issue before working on sound design, but it very well could be my fault. If anyone has any clue I would really appreciate it.

Thanks.


Sound Designer @ open Outcast

User avatar   24/7 Modder 24/7 ModderMember since: 16.06.2008, 22:11Posts: 4307Location: Oulu, Finland Likes: 7
 

 Post Topic: Re: Trouble with Sound Spots, Particle Sounds, and Roll offs
PostPosted 14.05.2012, 14:09 
According to my experience, sounds for SoundSpots must be picked from filesystem. Sounds selected from sound banks do not work.

And for sounds generally i would use SoundEventSpots.


Zip-line release 2012-04-24 (for CE2 & CE3) · C1 mod project: A mod called Entry
Assets · Blender: Destroyable object tutorial for CryBlend

- currently lost in New Eden -
  Trained Modder Trained ModderMember since: 13.10.2011, 00:35Posts: 294 Likes: 36
 

 Post Topic: Re: Trouble with Sound Spots, Particle Sounds, and Roll offs
PostPosted 26.05.2012, 10:10 
SoundSpots are actually meant for rapid prototyping with usual wav files afaik.
For serious development use SoundEventSpots only and make sure your FMOD events are properly setup in terms of is it set to 3D or is the falloff that you designed in FMOD Designer proper and not turned around and so on.